All checks were successful
Check flake.lock / Check health of `flake.lock` (pull_request) Successful in 18s
Check Nix formatting / Perform Nix format checks (pull_request) Successful in 2m50s
Check Nix flake / Perform Nix flake checks (ubuntu-latest) (pull_request) Successful in 9m55s
Check Nix flake / Build nix outputs (ubuntu-latest) (pull_request) Successful in 16m5s
Signed-off-by: ahuston-0 <aliceghuston@gmail.com>
48 lines
1.6 KiB
Nix
48 lines
1.6 KiB
Nix
{
|
|
config,
|
|
lib,
|
|
pkgs,
|
|
...
|
|
}:
|
|
|
|
{
|
|
services.hypridle = {
|
|
enable = true;
|
|
settings = {
|
|
general = {
|
|
lock_cmd = "pidof hyprlock || hyprlock --immediate --immediate-render"; # avoid starting multiple hyprlock instances.
|
|
before_sleep_cmd = "loginctl lock-session"; # lock before suspend.
|
|
after_sleep_cmd = "hyprctl dispatch dpms on"; # to avoid having to press a key twice to turn on the display.
|
|
};
|
|
|
|
listener = [
|
|
{
|
|
timeout = 150; # 2.5min.
|
|
on-timeout = "${pkgs.brightnessctl}/bin/brightnessctl -s set 1"; # set monitor backlight to minimum, avoid 0 on OLED monitor.
|
|
on-resume = "${pkgs.brightnessctl}/bin/brightnessctl -r"; # monitor backlight restore.
|
|
}
|
|
# turn off keyboard backlight, comment out this section if you dont have a keyboard backlight.
|
|
{
|
|
timeout = 150; # 2.5min.
|
|
on-timeout = "${pkgs.brightnessctl}/bin/brightnessctl -sd rgb:kbd_backlight set 0"; # turn off keyboard backlight.
|
|
on-resume = "${pkgs.brightnessctl}/bin/brightnessctl -rd rgb:kbd_backlight"; # turn on keyboard backlight.
|
|
}
|
|
{
|
|
timeout = 300; # 5min
|
|
on-timeout = "loginctl lock-session"; # lock screen when timeout has passed
|
|
|
|
}
|
|
{
|
|
timeout = 330; # 5.5min
|
|
on-timeout = "hyprctl dispatch dpms off"; # screen off when timeout has passed
|
|
on-resume = "hyprctl dispatch dpms on"; # screen on when activity is detected after timeout has fired.
|
|
}
|
|
{
|
|
timeout = 1800; # 30min
|
|
on-timeout = "systemctl suspend"; # suspend pc
|
|
}
|
|
];
|
|
};
|
|
};
|
|
}
|